As promised, our development cycle has delivered the next evolution of Textpattern CMS for you to try out prior to its official release. This release massively benefits from the distributed nature of git. It’s the culmination of a lot of hard work by community members who have worked on patches, features, documentation and good old fashioned graft.

It is presented in memory of Dean Allen, founder of Textpattern.

Download

You can either download from the links below, or from the GitHub project repository directly (please take a minute to ‘star’ our project too if you like it!)

File download

Zip format.
File size 1640 kB | Created | SHA256 checksum 3fb3d083d1f5db108a62e81afa49edf85be9198e20220ac41b394b857f4c188c
File download

Gzip format.
File size 1385 kB | Created | SHA256 checksum 0278ed9008b0a8b616161f82616e882f21014d35d27982c6276f0003133d1de5

If you’re undecided, you can give it a whirl in complete safety first on the revamped demo site kindly hosted by Pete Cooper. It’s using the new automated installer in 4.7.0 for lightning-quick rebuilds every few hours, not only of the beta itself, but also an environment to play with the bleeding edge development version.

System requirements

Please note that Textpattern 4.7 now requires PHP 5.4 or newer. PHP 7 is highly recommended.

What’s new?

Please see HISTORY.txt for a full list of changes that will appear in the 4.7.0 stable release. Before listing the changes, we would like to extend our gratitude to those community members outside the official devs who have gone above and beyond the call of duty to help bring this version to life.

In no particular order:

Some of the headline changes in 4.7.0 are:

Beta notes

Make sure that if you use this beta release, you also update to the final 4.7.0 version when it is released.

Do not use this beta release on a production site unless you have a working backup of both the site’s files and its database and know how to use it.

Please report any issues here, stating the beta version that you are using. Further beta releases may be required prior to 4.7.0 stable release, depending on issues reported.

Above all, enjoy!